Check out our new Work Transformation Summit page, and join our upcoming event to learn how leading organizations are building a smarter hybrid workspace for their employees.

Visit the page
Showing results for 
Search instead for 
Did you mean: 

Caller can only reach me if they know the extension / how to remove extension?


Hi there, 

I recently setup a Zoom account to enable VoIP phone calls. I assigned myself a number and when setting it up also had to choose an extension that is now registered as my business number. So when I know call the phone number I want to use for my business, it can only be connected if the caller knows the correct extension. Is there any way to get rid of this extension requirement? Is it possible for an external caller to just call the number and be put through without having to add an extension? I have a large group of elderly people who will access my business, and the requirement for extensions etc is very confusing for them. 


Thanks for any help you may be able to provide. 





Community Champion

Hi @OMF ,


Not knowing what your configuration in your Zoom web portal is, it seems that the phone number is assigned to the main company number and you might need to re-assign that number to yourself.  You can follow this article to re-assign the number to yourself


Hope this help,


I have this same question. We are a small business, with only one phone number. I ported our company's landline to Zoom phone (Zoom Phone US/Canada Unlimited Calling). I don't understand how to "re-assign the number" and that isn't really what we need, because we simply want people to be able to call our main number and NOT have to dial an extension. How do I set it up so someone can call our main number -- without an extension number -- and one of our on-duty receptionists can answer it on the Zoom phone app on any device? 


Also, with our current plan, will we be charged for US/Canada calls forwarded to a US/Canada mobile device?



Do you have multiple users who would answer the calls at the same time? 


No. Only one person at a time. We have 3 people in different time zones and each take shifts to answer the phones.


Here's a screenshot of my setup during business hours. 

You can see I set up call handling: Zoom application & my cell phone -- (I have tried these separately as well). It never rings to either the cell or Zoom application. Goes straight to a message. It is not the message pictured here.


I can see that Zoom phone is ideal for a large enterprise, but I spent 4 hours on Friday and as many yesterday, to no avail. Is there any way Zoom can create a separate set of SIMPLE instructions for small businesses and solopreneurs with one line only?


I understand, the Getting Started documents in Support are rather generic in style. I work for a small business though with one main number, and multiple users who have come and go throughout the day. We have a Call Queue set up to ring all users during the company business hours, and anyone available answers the call.


So, does each person have their own Zoom Phone User account set up?


Have you thought about setting the Auto Attendant to automatically Route To a Call Queue with the three members in it during general Business Hours? In the Call Queue you would add all three of the Users as members and Call Distribution as Simultaneous. Each person would then set their own user-level Business Hours according to their schedule.  Note: you can set the Greeting Prompt to Disabled.


When someone calls in, the app (desktop and/or mobile) would ring for those members are within their personal business hours.




Right now, we have only one "user" account we all share and log in to use as needed. (yes, we are still that small...)

I would consider getting a User account for each person so that they can set and forget about the business hours and won't step on the user settings that another person set up.


In the meantime though:

The Auto attendant and Extensions are an integral part of how the system works. What you can do is set the Auto Attendant Business Hours to 24/7 and set its Call Handling to transfer to your extension automatically.


All you need to do is:

  1. log into the web portal at;
  2. on the left click on Phone System Management under Admin and then Auto Receptionists;
  3. click the name of the Auto Receptionist that was established previously;
  4. on the right under Profile > Business Hours , click edit and select 24 Hours a Day, 7 Days a Week, and then click OK;
  5. below the hours set Greeting Prompt to Disable;
  6. click Edit next to Route To, select User in the drop-down list, and select your Name/Extension, and click OK.

Then under the Personal section on the right at the top select Phone, and set the Business hours and Call Handling for the hours when you really want Zoom Phone to ring.  Remove any Call Handling for Closed Hours, and set a customized Voicemail Greeting. I would also dial back your Wait Time from 45 seconds to 15 seconds for the Business Hours. 45 seconds its long time for the phone to ring unanswered without going to voicemail. 


Also see my previous note about removing your Cell Number from the Call Handling, and just logging into the Zoom app on your cell phone when you want to answer it there.


I hope that helps!



Thanks so much for the quick reply and assistance. I had an emergency come up over the past few days, so just now getting back to resolving the phone issue.


I was able to follow your instructions until step 6 -- when I try to select my name/extension (which would be "mail line" since we have no other numbers) it does not appear. I am given the following options:

  • auto receptionist (which would send callers into a perpetual loop)
  • call queue -- which doesn't work in our case because we only have one line
  • shared line group -- same as above
  • IVR -- which does work but this means no one is answering the phone
  • External contacts -- I could add my cell phone number here
  • Phone number -- I could also add my cell phone number here

See screenshot. 


I would love your help cracking this! Thanks so much.

You're welcome! 


For me the dropdown list for Route To is a little odd in the way it functions, you actually need to scroll UP in the list to find User, Voicemail, Message, Zoom Room, etc. Have a look, and see if you can scroll up in the list.


My hero. Did the trick.


I also set the business hours. During business hours, it gets routed to me or they can leave VM for other team members (auto responder extensions I have assigned). After hours, no option to reach a live person and I send it to VM directly. 


Looks like it's working. 


(P.S. Who ever heard of drop UP menu? LOL. Someone needs to help Zoom simplify the phone instructions for solopreneurs and small businesses!)

That's great! There are a lot of options to choose from, it can be overwhelming at first.


Drop UP menu's are the next HOT thing! Haha


If you wouldn't mind, please mark my previous post with the numbered list as the Solution, so that others will know if they have the same issue.





I am also having the same issue. I tried to article linked above, but it hasn't allowed me to remove the extension from our number. As with @mediatoronzoom , we are using this phone number for a small business, and simply need one main phone number to call. The extensions are unnecessary and cumbersome for our needs. Our expectation was that just one receptionist could receive all calls going to this main number, no extensions.


Does anyone have any suggestions/assistance?

Hi Gabriella,


Were you able to reassign your Company Number to your Zoom User record?


The extension is an integral part of the system, but you can just ignore it. If a person calls the number, and your Call Handling is set to Zoom Applications for the Business Hours that you set, whoever is signed into the desktop or mobile app with your Zoom User Account will get the phone calls directly.


I know this question was directed to Gabriella, and I would love your help with this as well.


I am unable to figure out how to reassign my company number to my zoom user record.


Moreover, how do I set a direct number? (Is this the same thing? Is this necessary?)


And even though I set it to simultaneously ring to my cell phone, it doesn't do that either.


Please take a look at the screenshots. This has really been confusing, so I am grateful for any guidance you may be able to provide.

See my other reply.


Also note that in Call Handling, you don't need to add your cell phone number separately into the Call Handling. You should log into the Zoom app on your cell phone when you want to answer there, and not in the Zoom computer desktop app. 😊 


Hi Gabriella,


Were you able to resolve your issue?