Showing results for 
Search instead for 
Did you mean: 

zoom meeting Add to google calendar results in System error please try again later. (403)


It is a Zoom Pro Account type. Using Chrome browser. Cleared cache and cookies. signed out and signed back in and error repeats, see attached screenshot. How do you fix it? Thanks for the help


Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello There,


Please follow these steps to integrate your calendar with Zoom

It says: "Add failed, the calendar-related access permissions are not allowed"

I looked at this thread:

while signed into zoom in google chrome, Adding meeting to google calendar still results in error: "System error please try again later. (403)" 

This used to work fine.

What Now ?

Community Champion | Zoom Employee
Community Champion | Zoom Employee



Are you the owner / admin of the account and have checked the required settings shown in the link I shared ?


Yes , I am the owner of the account.

The link You shared is long. Can you be more specific ?

Community Champion | Zoom Employee
Community Champion | Zoom Employee



Just follow the steps from "How to set up calendar and contacts integration" onwards. It's really straightforward.


How to set up calendar and contacts integration


  • Your admin can force you to use a particular service and restrict you from selecting calendar/contacts permissions. Contact your Zoom admin for more information. 
  • If you have schedule privilege for another user on your account, you will automatically see their scheduled meetings on your list of upcoming meetings and does not require the calendar integration to function. These meetings will be distinguished from your meetings by listing a different host under the meeting details. They can also be filtered out by selecting Me from the Meetings hosted by option at the top of the list of upcoming meetings.
  • When you assign scheduling privileges to other users in the Zoom web portal, you can choose if these users can manage your meetings that are marked as private in Outlook or Google Calendar. If the users cannot manage private events, they cannot see the invite link, meeting topic, or attendee list.
  1. Sign in to the Zoom web portal.
  2. Click Profile.
  3. Under Others, in the Calendar and Contact Integration section, click Configure Calendar and Contacts Service.
  4. Select a service. 
  5. Change the permissions for the service.
  6. Click Next.
  7.  Follow the on-screen instructions to grant Zoom access to the calendar/contacts service.
    • Google: You will be directed to Google's sign-in page. Sign in to your Google account. Click Allow to let Zoom access your contacts and Google Calendar.
    • Office 365:
      • Authorize with OAuth 2.0: Ensure this option is checked. 
    • Exchange:
      Note: When impersonation account is enabled, you do not have to enter a password for calendar and contact integration, and all your meetings created from the Zoom web portal or on Outlook are synced to the Zoom client or web portal.
        • Exchange login username or UPN: Enter the username or UPN associated with your Exchange account.
        • Exchange login password: Enter the password associated with Exchange account.
        • Exchange Version: Select the version of Exchange. If you are uncertain of the Exchange Version, please contact your internal IT team for more information.
        • EWS URL: Enter your organization’s EWS URL. Contact your internal IT team if you do not know the EWS URL.

After allowing access, you will be redirected back to the Zoom web portal, which will indicate the permissions for the calendar and contacts integration.


If this response helps, please accept the answer as an accepted solution, so others can benefit as well.

@sachinzoom it is not working. I will show you it is not working with screenshots. It is too much time and effort on this nonsense,
We need to resolve this soonest

step 1: sign into zoom account > Profile > Others > select Configure Calendars and Contacts Service. see step x1.jpg


Step 2: select Google on next screen. Calendar & Contacts: Read & Write checked. see step x2.jpg

step3: Select the Google account to associate Calendar & Contacts and sign in. step x3.jpg


step4: Press Continue on next screen with first three choices already checked. step x4.jpg


step5: Zoom error pops in pink: Add failed, the calendar-related access permissions are not allowed. see step x5.jpg



Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello @iforgiveu @pg002 


Sounds like calendar permissions are turned off at account level. Can you please check ?


Account management -> Account settings -> Meeting -> 

Below is the example config if you are using O365:




What is the resolution Zoom??? Same problem here and followed the exact instructions.

It used to work perfectly and suddenly stopped so it's clearly an issue on your side.

Please provide a clear answer.

Thank you.