Showing results for 
Search instead for 
Did you mean: 

video on Mac: grant permissions issue



I don't see the Zoom app icon in System Settings>Privacy & Security>Camera to provide the required permissions. 

I've tried: 
- Check another permission in System Settings>Privacy & Security>Microphone -  it works as expected. I can see the Zoom app icon and allow the app to use Mic. Accordingly, I can make a call with Zoom, but without Video.  
- Reinstall Zoom. Uninstall it completely and install it from the stretch. Same issue. 
- Uninstalling the Zoom app with the 
CleanMyMac app doesn't help too.  

- Check the Camera permission tab in System Settings>Privacy & Security with another app (Skype). It works as expected. After installation, the Skype app icon appeared in the Camera permission tab and I'm able to grant permissions for the app. Also, I can make a call with a video with the Skype app and Google Meet. 

App version
I use the latest version of Zoom 5.15.5 (20753)
Mac OS has also the latest update 11.7.8 (20G1351)
The camera is built into the iMac.

So, it looks like the Mac OS works as expected but I can't grant video permissions for the Zoom app. 

Any help/insights would be greatly appreciated!


Zoom Moderator
Zoom Moderator

Hi @RossK welcome to the community and thank you for your question! 🙂 It looks like I was able to find some resources that may help! 


First, lets try to Reset the Privacy Database and restart zoom. You will be asked to grant the access again when you try to access camera/microphone.


1. Open terminal 

2. Enter the following command to reset camera: tccutil reset Camera

3. Restart Zoom and attempt to grant the access again 


Let me know if that works! If not, let me know and we can try something else, thanks! 

Zoom Community Moderator

Have you heard about Zoom AI Companion? ➡️ Check it out!

Thanks to bring a new idea. 
Camera permissions were cleaned up after applying this command. Unfortunately, Zoom can't request Camera permissions because it is crashing on this step (number 3, in your list) 
Debug stack looks like 

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

I've checked it several times. Re-install Zoom doesn't help to resolve the issue. 
All other apps that had been using Camera stopped using Camera also and I can't grant access again, because the list of apps is empty (see screenshot)

Screen Shot 2023-08-03 at 6.00.46 PM.png

After re-installing the Skype app, the Skype icon not appeared in the Camera permission tab and I'm not able to grant permissions for the app. 


Zoom Moderator
Zoom Moderator

Hey @RossK interesting find... I was just Googling this issue because you mentioned Skype not popping up to give permissions. My other suggestion was to manually add the permissions, but I would rather try to get other applications you use to be able to configure those camera settings.


I did come across this and watched the video, and the user had some different softwares trying to access camera permissions (OBS, Zoom, Teams, etc.), take a look at that troubleshooting article and let me know what you think? Some of the comments in that are pretty helpful as well if none of the suggested help.


I wish I could replicate this issue to test for you, but unfortunately I am not on the same macOS version nor seeing the same from my end. 😕

Zoom Community Moderator

Have you heard about Zoom AI Companion? ➡️ Check it out!

yeah, the issue is with the TCC.db database. I fixed it in the manual. 




sqlite3 ~/Library/Application\ Support/ 

insert into access values ('kTCCServiceMicrophone','<AppBundleURLname>', 0, 2, 2, 1, null, null, null, 'UNUSED', null, null, 1669648527);



where <AppBundleURLname> can be found in 



grep 'BundleIdent' -A 1 /Applications/



but later I found a better way to use


Also, I tested some other tools but it doesn't work for me