Showing results for 
Search instead for 
Did you mean: 

recent zoom client on centos/rhel/sl7 fails



I usually update to zoom clients on my centos7 like machines by downloading
This worked fine up to zoom-
The new version now is and fails, because it requires GLIBCXX_3.4.20 and 21 , which are not available for CentOS7.
Using the "official" download via
I still get 
Version 5.13.4(711)  ,  which works fine.

Are there plans to have a special CentOS7 download on ?

Thank you! Zoom is great!!




When invoking zoom, it prompts for an update. Clicking on the link and then downloading the required RPM for Centos 7 brings up a situation where zoom is no longer executable as it depends on GLIBCXX_3.4.20. The specific error message is  as follows:

zoom: /lib64/ version `GLIBCXX_3.4.20' not found (required by zoom)
zoom: /lib64/ version `GLIBCXX_3.4.21' not found (required by zoom)
This is for version zoom-

Even the current workaround to download from the "official" download URL via

which provides zoom.x86_64 0: is NO LONGER working as it is being prevented from signing up as Zoom requires a higher version to sign in.

Please note that Centos 7 is only scheduled to be EOLed in June 2024 and would appreciate if Zoom could continue supporting Centos 7 till then. 


Just a note that a version of the downloads page that is linked from the client (via an 'update' button) incorrectly provides 5.13.5 as a download for CentOS 7. It's possible that earlier versions of the download page had a similar issue. The current Linux downloads page correctly provides the latest version that runs on CentOS 7.


Very strange. But at least now official (from ) :

End of support for CentOS 7, Red Hat 7, and Oracle Linux 7
With this release, Linux users on the CentOS, Red Hat, and Oracle distributions must be on version 8 or higher to continue to receive additional Zoom app updates. Devices still using CentOS, Red Hat, and Oracle 7 or below will have 5.13.4 (711) as the most recent version available.


I hope this version will be accepted by Zoom servers and still receive security updates. 🙄

There is a flatpak (currently version available:
My tests ran fine on Scientific Linux (CentOS) 7.9 


Never mind getting version updates- now users with the last Centos 7 version of Zoom cannot even log in or join a meeting.  And yet the Centos 7 version is still offered by Zoom for download.  Centos 7 is not EOL until 6/30/2024. 

What is the rationale here?  With respect, users on the Centos 7 version should still be able to log in an join meetings.  There are many, many users still on Centos 7 that would like to use the app itself (not just the web app).  Thank you.