Showing results for 
Search instead for 
Did you mean: 

macOS: URL won't launch Zoom anymore after latest update


I have no trouble running Zoom by entering the meeting ID, everything works just fine.

However, since I updated Zoom, I cannot join a meeting by clicking on a URL, for example a URL that is in a calendar invite. When I click on the URL I do get the pop-up asking "do you want to allow this page to open" and I click "Allow" and zoom app starts, but does NOT take me to the meeting. I can go to the meeting by copying and pasting the meeting ID (which is at the end of the URL), but it does not happen automatically anymore. I have made sure all the "Security and Privacy" settings are correct, and anyway, Zoom works fine if I enter the meeting ID manually, so the settings MUST be correct or it wouldn't work in that case.

Hope someone has a solution.


Community Champion | Zoom Partner
Community Champion | Zoom Partner


Did you try to use another browser for this kind of issue?



I am Zoom Enthusiast (Part of PT. Kayreach System, Indonesia Authorized Reseller, Certified Zoom Room, Zoom Phone, and Pro AV Integrator)


I'm having the same issue - I'm using SAFARI - could this be the issue?


I'm also having a similar issue. I cannot launch meetings when I "allow" Zoom to do so. Then it gives me an option to use my browser (Safari) which I do. I remain in thumbnail for the whole session as there's no gallery option available, and my computer dims every 4 minutes (I realize I can reset this on my computer). Any fix for this? Uninstall and reinstall?



 I am also having trouble launching Zoom meetings, since the last release (I believe).  I'm using Chrome on a PC.   I get the same result whether using browser or from the desktop app.  The meeting seems to launch, then freezes.  I click on the X (exit), the message asking if I want to wait for the program responds or close appears.  I select Close, the dialog seems to close and the meeting launches and I'm in.  This happens consistently.


I'm having the same problem using Mac mini with Safari.  Is there a fix for this?


I too have just bought a MacBook Air and can eventually get into meeting but not automatically.  My problem is that there is no gallery button - how do I fix this?



Is there still no way to tell Safari to just open the freaking meeting from a URL, the way Chrome can??


On my older MacBook Air, Chrome plus Zoom are a massive power draw, so I'm increasingly using Safari whenever I can.  Chrome would directly open the Zoom meeting, but with Safari, EVERY TIME I click a link in a calendar, Safari insists on saying "Do you want to allow this page to open"  I can't find any setting to say "YES, ALWAYS for heaven's sake." 


Please tell me I'm missing some easy setting 🙂