Showing results for 
Search instead for 
Did you mean: 

Zoom unusably slow on Ubuntu 22.04 ... possibly issue with nVidia drivers/hardware


I use zoom a lot , my work is pretty dependent on it.  Previously it has worked pretty well but I have just had to change machines and move from Ubuntu 20.04 to 22.04.  Now zoom is unusably slow from launch: even entering my Email address and password is hopelessly slow.  I think this is an issue that is not unique to zoom and I've seen something similar with Chromium and derivative browers, Rstudio, even Ubuntu disks.  I think this is an issue with the graphics driver and hardware acceleration as switching acceleration off in Chromium solves the problem there.  I think it may be related to this: but the solutions thre don't work for me.  The machine is a "Clevo" with "AMD Ryzen 7 5800H with Radeon Graphics" and "GA106M [GeForce RTX 3060 Mobile / Max-Q]" (from lshw).  I would really love an early fix for this!  TIA, Chris



I haven't been able to get the Zoom client to work well with my Ubuntu 22.04 install. I am joining through the browser. I did notice the Zoom client was so slow it was unusable before abandoning it. I found that hardware acceleration was causing the slowness. Same with Chrome. In Chrome, I select Settings, expand Advanced and select System. I then toggled off `Use hardware acceleration when available` and that completely fixed my Chrome. It helped in the Zoom client when I was trying to use it, but if your experience mirrors mine, I wasn't able to share my screen in the Zoom client. I have started using Chrome to use Zoom and it allows me to share my screen.


I recently switched from Kubuntu 20.04 to OpenSuse Tumbleweed with KDE and have the same problem. I don't use Chrome. My browser is Firefox, but I use Zoom as a standalone app, not in a browser. I also don't have an Nvidia card, just the onboard Intel graphics in my Thinkpad. Any advice would be appreciated.


I recently upgraded to a newer version of Zoom (currently on version 5.10.7 (3311)) and have since reverted back to using Wayland on Ubuntu 22.04. With the later Zoom client, I'm able to join, share my screen, etc. without issue. I do occasionally see a crash on application startup, but I report it and continue on and it seems to work. I can share my screen and specific application windows and it seems to work well. Not sure if the later versions of the Zoom client would work better for OpenSuse Tumbleweed.

Just upgraded to 5.11.3 (3882) for Ubuntu and checked and I am using Wayland.  No change: zoom is completely unusably slow for me and this has been going on for weeks.  Time to give up zoom for me I suspect.  I am no fan of Gurgle but I find now that I am using Gurgle meet: no time limit, no participant limit, not restricted to people with a licence (unlike M$ teams) and screen sharing works.  It's not as good as zoom when zoom was working but this is becoming simply a time waster for me.

I'm sorry to hear this. I just upgraded to 5.11.3 (3882) today and don't have this issue. Did you make sure that hardware acceleration is disabled? Settings > Video > Advanced > Use hardware acceleration for receiving video (uncheck)?

It is unset.  (I do find it  a bit bizarre that a possible solution to crawling screen handling is to _un_set hardware acceleration but accept that does seem to be the case for a number of programs at the moment.  It is definitely unset in zoom and zoom is unusable.

I do agree that unchecking an option that is supposed to help video performance could actually hurt video performance, but can also recognize that with the plethora of video devices out there that some devices may not be handled appropriately. Wish I had more suggestions for you. I just know what worked for me on my Rog STRIX system with AMD Ryzen 7 4000 Series graphics. The only other thing I tried was disabling Wayland and going back to XOrg. I've seen some posts that claim that works. I hope you find something that works for you. I know I spent about a week trying various things before falling back to Chrome and then tried (skeptically) a later version of Zoom that seemed to claim it supports Wayland and being pleasantly surprised it actually worked.

I really appreciate such a humane response: thank you tmousawnf.  One question: can you clarify "falling back to Chrome"?  You were running zoom sessions in Chrome (Chromium?) browser windows?  Aha I see .  Yes, I guess I could try that and see how it compares with Gurgle meet.  I guess I can also switch off Wayland at least for a trial but (a) a bit wary of taking up yet more time trying to debug a program that has already wasted so much of my time and (b) strongly suspect that even if it does fix zoom it will probably break something else!  Anyway, hugely appreciate your responses.

Yes. I just launched my Zoom meetings through the Chrome browser. Still dealt with having to disable hardware acceleration (again, very counter-intuitive). Chrome allowed me to share my entire screen, but I couldn't share specific windows... when I did a specific window, there was no way to close the Zoom session (I'd have to kill Chrome).


I feel you on the wasting time debugging Zoom. On the flip side, I started out trying to set up a laptop for my new job on Windows 11 using WSL2 and IntelliJ IDEA (working mostly on Java REST API with a MySQL database in the backend) and things seemed to mostly work until they didn't and I spent weeks trying different things to get WSL2 to work with IntelliJ IDEA such that I could debug, etc. and I just couldn't find any way to make it work. That's when I decided I'd try to set up Linux on my laptop and it probably took me about a 3 or 4 days to get to a point where it mostly worked (or at least I could live with it for now until I found more time to figure out the final things that were annoying me).


Ubuntu 22.04

AMD Ryzen 7 3700X 8-Core @ 16x 3.6GHz
32 Gb fast RAM



PC goes very slow when Zoom is working.


Zoom video coming from me is very slow, unusable if either Firefox or Chrome runs along with Zoom. If I stop both browser then it is useable. Unfortunately I do need a browser when I am on zoom meetings. It is not about memory or cpu usage, both are very low. Maybe the graphics issue mentioned above causes this. My video card is Radeon though, not nVidia.