Showing results for 
Search instead for 
Did you mean: 

Zoom creates infinite notifications when there is no microphone




I am on desktop using Linux Mint 20 and i don't have a microphone. If i click the Join Audio button during a meeting, this happens: 


The mass of errors stops me from doing anything else. I have to drop down to TTY and pkill zoom.

It's annoying because i do have audio output and i want to play sounds when i share my screen, but i cannot join audio at all. 




Came here looking for a solution to the same issue.  The other thing to add here is that it will occur if the mic becomes disconnected.  Even if it is then reconnected, the infinite notifications continue.


OS: Arch

WM: awesomewm, i3


Is there a solution to this?


Zoom is practically unusable if a mic is not available. This issue is critical!


EDIT: Distribution: Arch Linux; Desktop Environment: KDE Plasma


I've found a workaround on most Linux systems.


Most likely you are running PulseAudio (practically all even remotely modern Linux distributions do this, unless you've specifically decided to run ALSA only etc.). One can create a dummy input (audio source). Run:


pacmd load-module module-null-source


You don't need to run this as root (the regular user has their own pulseaudio daemon on most systems).


Zoom stops nagging now, as it finds "a mic".


However, there are actually three issues here: No situation should create infinite notifications. Moreover, they should not steal focus!


Zoom should use the desktops built-in notifications instead of insisting using it's own notifications at least as an option. The user probably wants to have notifications in one place, not several different places.


Also, this is a regression: previously, Zoom did not send infinite notifications.



The most recent release of zoom resolved this issue for me.

Version: 5.9.6 (2225)