Showing results for 
Search instead for 
Did you mean: 

Wayland screen sharing broken on high-res (beyond 1080p) displays


I am on Fedora 36 using Zoom 5.11.9, using GNOME under Wayland. Normally I perform most of my work on an ultrawide 3440x1440 monitor. When I attempt a screenshare from this resolution, it appears that most, if not all people in the call (who are likely probably running at 1920x1080 or 1200) aren't able to see my screen. From the attachment, my screen appears distorted in the eyes of others in the room. I have noticed that if I scale my resolution down to 1920x1080 (which is my laptop displays' native resolution), my screen appears just fine. So I'm going to rule this down to Wayland and resolutions beyond 1920x1080 (or 1200).


If I run an X11 session, I notice that the screenshare scales down to fit 1080p monitors, but is otherwise perfectly visible. This is sort of the behavior I was hoping for under Wayland as well.


If it matters - I am connected to the external monitor via DisplayPort. I've tried setting the refresh rate to 60 or 100 hz, but that had no effect.



Ways to Fix Screen Sharing Problems

Besides the above-recommended solutions, users have fixed their screen sharing problems using the following methods:

Restart Your Device

A restart often resolves most computer problems, including screen sharing issues. If using a Mac, go to the Apple menu and choose Restart. And if you are using a PC, open the Start menu, select the power option and click Restart.

Terminate all Browser Processes and Clear Cache

Sometimes, closing your browser may not be enough to eliminate the screen sharing problem, as it might still operate in the background. To end browser processes, use the Control + Delete + Alt shortcut on your PC or the Quit + Function combination if using a Mac. Besides this, you should also clear your browser cache. The reason is that screen sharing is a graphics-intensive process. So, if you are using an older processor, you may need to get rid of some memory to make room for screen sharing.

Force-Quit Running Applications

Quit all Running Apps, including the app you are trying to share the screen. After that, try using the screen sharing feature again.

Edit Permissions

Modern apps come with permissions you can control. Sometimes, security permissions might trigger screen-sharing problems. If that is the case, follow these steps to edit permissions:

For Macs

Click on the Apple menu, then choose the System Preferences option.
Navigate to the Security & Privacy section and hit the Privacy tab.
While there, look for Screen Recording on the left options menu and click on it.
After that, click on the lock icon at the bottom of the window to edit security permissions.
You will see several apps with the screen sharing feature listed on the right side of the window. Click on the checkbox next to the app that is giving you trouble.
To activate the changes, you need to restart the app. usually; a notification window will ask you to do that.
For Windows PCs

To manage permissions for a single app, follow these steps:

First, go to the Start menu, right-click on the app’s tile and choose More > App Settings.
Wait for the Settings screen to open, then navigate Settings > Apps > Apps & Features.
From here, choose the app and click Advanced Options.
When you scroll down to the App Permissions section, you will see all the app’s permissions. You can then toggle the app permissions to allow access. If you don’t see the App Permissions section, it is most likely the app doesn’t have any permission control.
Besides this, you can also manage permissions for all the apps on your PC. To do this, follow the steps below:

First, go to Settings > Privacy, then navigate to the App Permissions section.
Scroll down in the right pane to choose the apps you want to access.
In the left pane, you will see all the available permissions. If you click on each of them, you will see what that permission does. You can then change permissions for screen sharing.



Rachel Gomez

Nothing about this reply has anything to do with my platform (Linux).

Did you get it to work?  I've tried versions 5.12.2 5.12.6 but screen just shows to be black with different resolutions

I would suggest trying a resolution with an aspect ratio of 16:9. I am using the Zoom flatpak (v5.13.7.683).


I have the same issue. 

I recently purchased a nice 21:9 widescreen monitor. Since then I've noticed that when I try to share my screen on Zoom, it doesn't work. Participants see a black screen. In my preview I see a garbled screen, same as your screenshot.


Trying to share an application window instead of the entire desktop does not work, and results in the same issue. Changing the monitor resolution to 2560x1440 (16:9) fixes the issue and allows me to share desktop or application.


Changing into x11 fixes the issue and lets share desktop and applications as normal.

Using the builtin Gnome screen recorder works with wayland regardless of desktop or application sharing.


I'm sure zoom + wayland + widescreen is a fairly niche combination, but it would be good to get it fixed as this doesn't happen on other platforms.


I am also having this issue. While my monitor is not an ultra-wide as others have mentioned, I am also experiencing distortions with my 1680x1050 (16:10) and attempting to share just a window does not remedy the issue as well. The only solution, as mentioned by others, is to drop my resolution to 1600x900 (16:9).


I have not found a true solution currently but will update if one is found.


Would be great if we can get acknowledgement from Zoom that they are aware of this problem. 


For what it is worth, another solution is to use the browser client instead of the zoom desktop client. When using the browser, sharing works as expected. Problem is not all meetings allow use of the browser client.