Showing results for 
Search instead for 
Did you mean: 

Untrusted Servers certificate problem


Untrusted Servers certificate problem   ....  why this error msg shown in the zoom meeting?



Hi @Martuza 


This could be a few things.


Your operating system by have pending updates. It could be missing the newest trusted Certificate Authorities. On Windows, for example, check for Windows Update.


Your system time may be drastically wrong. Check the time (and date) on your computer and correct it if necessary.


You Zoom client may need updating. Check for updates under the Help menu in Zoom.


You may be on a network that is blocking Zoom, and that you requires you to authenticate on a splash-screen somewhere. Like on a public or private campus network.


I'd suggest also restarting your computer.


Post back here with the results of any of these.


Or if any of these steps solve your problem, please click on Accept as Solution on this answer. This was all help the Community know we found a solution within this thread.


Please also give it a thumbs up, if you like. 


If you need any more help, just post back here.





My IT department tried all of these and they aren't working


I'm in the same boat.  I have been getting this Unable to establish secure connection to Zoom error for the past several months.  I have been in contact with both Zoom and my IT department.  I have tried the following and nothing seems to work:

 - my date and time are correct

- I'm working from my home PC (which was purchased at the beginning of the pandemic - a Dell) and using a corporate Zoom account.

- I have uninstalled and reinstalled zoom (including using the CleanZooom tool).

- We use Okta as our SSO, and it only seems to happen the minute Sign into Zoom using my Okta login.

- I can use Zoom, but have to click on this stupid error every 30 second or so if I do.

- I can use Zoom (without logging in), but then do not have all of the options available, but can do a basic meeting.

This has been torturous.  Zoom help just keeps asking me the same silly questions, but don't seem to have an answer.  I'm hoping that someone in this community might.  Where does this stupid certificate reside anyway?



Community Champion | Zoom Employee
Community Champion | Zoom Employee

@KPU  @tmag13 @Martuza  -> Thanks for reaching out!



Please see the below link for more information on our certificates, specifically : Firewall rules for certificate validation


Let me know if this helps. 




We have seen this at start-up on Windows machines, if that is the case for you then take Zoom out of autorun, it doesn't cause any issue.  The error looks like it is a certificate error, but what we are seeing is an authentication error, so two fixes, firstly, open Zoom, logout from the Zoom client and reboot, or, secondly, uninstall the Zoom client and reinstall it, then reboot.
Hope this helps


Encountered this issue after updating Zoom on Ubuntu 20.04 this morning. Issue seems to be solved after updating the .pub using rpm --install, and logging out then back in. Glad I waited for a day that had no meetings scheduled to update this app.