cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to screen share in ubuntu 22.04

13mehuls
Attendee

I installed zoom on my freshly installed ubuntu 22.04 LTS and I faced a issue where i was only able to share whiteboard instead of my screen and there is no option other than that. How can i enable screen share? Is there any problem because ubuntu adopted wayland instead of xorg?

79 REPLIES 79

It works. However GUI is different.  Say you have  two images opened as shown below, it does not tell you which one is which.

However when it comes to apps and browser tabs or windows for example,  it does tell you which one is which.

damirx_0-1655868843798.png
Honestly I like the latter GUI better. 

hi shreedhar

i am able to start screen share but while clicking on the panel for various options like stop screen share or share other window or even trying to mute or unmute the zoom app freezes and asks to either wait or force quit the application and sometimes it just crashes the whole application. also i dont think there is an option to share sound while sharing the screen.

The option to also share sound is there.  I did not experience any crash of the app and was able to stop and resume sharing with no problems.

damirx_0-1655869492823.png

 

I have 5.11.1 (3595) installed with Ubuntu 22.04 completely up to date and zoom still crashes when screen sharing and using Wayland 😞 . Let me know if there are any logs or something I can share to help fix this issue.

I have 5.11.1.3595 too. On Ubuntu 22.04 (Wayland). I.e. it's GNOME 42.
Zoom didn't crash on screen share but didn't share the screen either.

I have this:

dayfuaim_0-1658319771754.png

So I can conclude that the bug is still here.

 

UPDATE:

Release notes of June 20, 2022 version 5.11.0 (3540) states: "Resolved an issue regarding sharing content on Gnome 41 with Wayland".
I think now it's time to work on GNOME 42 fix.

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

@dayfuaim

 

 Thank you for bringing this to my attention. I am working on this now. 

 

Brandon


Brandon (he/him/his)
Zoom Community Champion
Have you heard of Zoom AI Companion?

5.11.3 (3882) works for me on Ubuntu 22.04 using Wayland.

Thanks.

rico_gini
Listener

Still does not work with version 5.11.3 (3882) on Ubuntu 22.04 with multiple screens on Wayland. Shared  screen is always black. It works if I use only the notebook screen and no additional screens. I also tried to share only windows - no success. But might be related to the Gnome version - 42.2.

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello @rico_gini

 

 Engineering is asking if the issue is on XORG/x11 of GNOME 42 Fedora? They are asking for client logs to review. Can you please submit a support ticket to our team so that we can pull client logs from either your machine or any other user that is running into this issue.

 

Thanks, 

Brandon 

Internal note ZOOM-316546


Brandon (he/him/his)
Zoom Community Champion
Have you heard of Zoom AI Companion?

I use Ubuntu 22.04 with Wayland, Gnome 42 and multiple screens. Latest version 5.12.2 (4816) still does not work. I tested it also with single screen. I posted my logs under the issue ZOOM-316546.

ajfriesen
Listener

I just updated my ubuntu instance to 22.04.

 

I have the latest zoom version as of writing this: 

Version: 5.11.10 (4400

 

I am running on a doula monitor setup.

I can not share my screen at all. Only whiteboard and system capture.

 

Is there a way to keep wayland and share screen?

I read the release notes and saw quite a couple of bugfixes regarding wayland.

 

Can I assist with any logs?

YaBoiB
Community Champion | Zoom Employee
Community Champion | Zoom Employee

@ajfriesen

 

 All logging processes are handled through our technical Support group. Would you please submit a ticket to that team? 

 

Thanks, 

Brandon 


Brandon (he/him/his)
Zoom Community Champion
Have you heard of Zoom AI Companion?

ekalfwonS
Listener

Problem is present again in Zoom 5.11.10 (4400) on Ubuntu 22.04.   The only options are "Use System capture" and "Whiteboard".  "Use System capture" doesn't do anything. 

ekalfwonS_0-1663353376924.png

 

rcalhoun
Listener

UPDATE 9/18/22

I was able to fix screen sharing in XFCE Desktop Environment. I installed a package for the Weston Compositor, this apparently installs all the wayland files. I used the command >sudo apt install weston  It then recomended another package which I also installed. I then ran weston from the command line and it popped open a window with a terminal. Wasn't much to be done there other then to confirm that the package was installed and it could create a window and terminal in the XFCE environment. Restarted the computer, logged in and fired up zoom and works like a champ! 

I can share individual apps or the entire desktop, and as an added bonus, when sharing the entire desktop, I can scroll through all 4 of my virtual desktops, so the screen sharing has full cooperation with XFCE. Beautiful! 

_____________________

Original Post:

 

I figured I would reply here since I am having a very similar problem in that screen sharing is not working when I join a meeting. This is critical since I am taking a programming class online and it is imperative that screen sharing work.

Quick History:

Zoom screen sharing worked just fine about a year ago, at some point I updated Debian and Zoom and screen sharing was broken. I was able to find this thread and was able to make sure I was using X windows and I was again able to share the desktop only, where as before I could share individual screens. Summer break goes by I have again updated Debian and the Linux kernel a few more times, and of course I have updated Zoom to the latest version, and once again screen sharing is broken.

 

My exact problem is this: When in a hosted meeting, if I click on the 'share' (or try alt 's') button, the button flashes in recognition that it is being clicked on, but nothing happens, no error, no dialog box, nothing. I have checked all my zoom settings and have made sure screen sharing is enabled, I have checked and unchecked all possible combination of settings and nothing makes a difference. Other students (Windows) are able to share screens without issue so it is not a host setting issue.

 

In addition, I have tried joining using both Chrome and Firefox by clicking on a session link with no solution, I have tried opening, logging in the desktop app and joining the meeting and that has also not worked. I have also tried hosting a zoom session from my Google Pixel 4a cell phone, then joining from my desktop and again I am unable to share the screen from the desktop. 

 

All other Zoom functions are working correctly including sharing a whiteboard, so it is obviously capable of opening separate windows. All functions are operating correctly, video, audio, etc etc.

 

System Details:

Debian Version 11 (bullseye), Linux Kernel 5.10.0.18, Desktop Environment Xfce 4.16, Zoom Version: 5.11.10 (4400)

 

I have modified the /etc/gdm3 config file to Wayland = False (Note* This actually fixed screen sharing the first time)

Verified I am running X11 by running the command:

sudo echo $XDG_SESSION_TYPE
x11

 

I also have all the Gnome desktop binaries installed although I do not use Gnome as my Desktop Environment. I can offer up logs, screen shots, etc if it will help resolve the problem. Thank You for your prompt attention to this situation. I will update this if I am able to find a solution in the interim.

Robert

tangosierra111
Listener

I was resolved by going to `chrome://flags/#enable-webrtc-pipewire-capturer` and changing the value from `Default` to `Enabled`.

then

Search for the **file.conf** in **/etc/gdm3/** in my case, Ubuntu 20, it's **custom.conf**

```
sudo nano /etc/gdm3/custom.conf
```

uncomment the line

`#WaylandEnable=false` to be `WaylandEnable=false`

then `reboot`

"_uncommenting that line will use the Xorg display manager instead of Wayland_ "

cygakob
Listener

I've just installed "Version: 5.12.2 (4816)" on "Ubuntu 22.04.1 LTS". Still doesn't show me anything but whiteboard to share.

cygakob
Listener

I've just installed the latest zoom "Version: 5.12.2 (4816)" on "Ubuntu 22.04.1 LTS".
It still shows only whiteboard to share.

I was resolved by going to `chrome://flags/#enable-webrtc-pipewire-capturer` and changing the value from `Default` to `Enabled`.

then

Search for the **file.conf** in **/etc/gdm3/** in my case, Ubuntu 22.04, it's **custom.conf**

```
sudo nano /etc/gdm3/custom.conf
```

uncomment the line

`#WaylandEnable=false` to be `WaylandEnable=false`

then `reboot`

"_uncommenting that line will use the Xorg display manager instead of Wayland_ "

cygakob
Listener

I saw this workaround in this thread.
However, switching to Xorg just to share things in Zoom is not a viable option really.

rakibulinux
Listener

Firstly you need to install the Xorg package

 

sudo apt-get update
sudo apt-get install xserver-xorg

In this file /etc/gdm3/custom.conf (to access it for editing, you could run sudo nano /etc/gdm3/custom.conf), uncomment (remove the leading #) this line

#WaylandEnable=false

To

WaylandEnable=false

save and exit.

 

Then run this command in the terminal to restart gdm3

sudo systemctl restart gdm3.service

 It will log out and log in automatically. Just wait...

Thanks for reposting the same thing others have posted before.  But as cygakob and others have pointed out, changing from Wayland to Xorg isn't a viable solution for most people.

marajah76
Listener

Hi, everybody

I had the same problem. My OS is Ubuntu 22.04 and Zoom is 5.12.9.  I was running on Wayland but with xorg driver (I can't remember why).

So I went on "software & updates" - "additional drivers" and selected the latest NVIDIA proprietary driver (or the open source if you prefer, actually ver 520).

After a restart everything is working fine.

Hope it could help

bugfixer
Listener

I can not share on Ubuntu 22.04, Zoom 5.12.9, Gnome 42.5, Wayland, Mesa Intel® UHD Graphics 620 (KBL GT2) graphics card.

rogergray820
Listener

I am also facing the same issue I updated my ubuntu yesterday and when I want to share my screen there is only one option in basic WHITEBOARD and in the advance options there is a portion share, I tried with portion share but it only shows a black screen, but I am able to see to my video during screen share on the black screen

Gasp0de
Listener

This still does not work after a year. I found that the most viable solution is to switch to different, better programs like Jitsi Meet oder Big Blue Button.

adiman
Listener

Hi. There is a straightforward solution to this, which does not require using the browser, or using some third-party virtual camera. Go to Settings -> Users, and click on 'Unlock' on the top-right corner. Then, logout, choose 'Ubuntu on Xorg' in the settings icon on the bottom-right corner, and login again.

This is not a "solution" it is a "workaround" that requires you to downgrade your system (by switching to Xorg instead of the standard Wayland).  A solution would be to fix the Zoom software so it works with the standard Ubuntu OS.

AnthonyC
Listener

This problem has been fixed. However, if you updated Ubuntu after installing Zoom, you're going to need to reinstall the Zoom client. 

  1. Uninstall There's two places it could be installed, remove from both:
    • Ubuntu Applications > Zoom > Uninstall
    • `dpkg -r zoom`
  2. Install it from their deb package: https://zoom.us/download 
    • You'll likely get an error, just `sudo apt -f install`
  3. Fixed.

This is the actual solution, uninstalling and installing the latest version solves the problem. The others are just workarounds

FuriousGopher
Listener

The issue with Ubuntu 22.04 is that it now uses a display feature called wayland by default, while in versions prior to 21.04 Ubuntu defaulted to using xorg as its display server. Wayland does not support screen sharing by default (until now, at least!).

To check which display system your Ubuntu is using, please enter this command

echo $XDG_SESSION_TYPE

If the above command outputs wayland, your system is using wayland.

In order to use screen sharing, we have to disable wayland and enable xorg (x11). To do this,

Please go to this file

sudo nano /etc/gdm3/custom.conf

Uncomment this line.

WaylandEnable=false

Reboot your system.

Voila! You can share your screen. You can confirm this by re-entering this command.

echo $XDG_SESSION_TYPE

Now it should display x11.

Wayland doesn't support screen sharing natively because it's a security issue. Gnome does provide options for screen sharing (and other programs do support it), and I am not going to switch back to some legacy program just because zoom won't implement it. Instead, I'll try to convince my peers to use other software like Jitsi Meet or Big Blue Button.

frankreebig
Listener

Same happening with me, and I have tried to resolve it to see tutorials from YouTube but not successful to resolve it. I'm facing this issue from last month.

Thanks in advance.

moise-mulungu
Listener

Hello Guys, thank you for your solutions, I finally fixed the screen share issue, but I am having another issue with the background image: I can't change any image or upload an image. Any suggestions?

Jgel
Listener

I found this solution: When I log into Ubuntu I click on my username, then in the bottom right I click on the gear icon and Ubuntu on XORG, then I enter my password and then I can share with no problems.

marc_ots
Listener

I read through this thread, but am still stuck with enabling screen sharing. I just installed a fresh copy of Ubuntu 22.04.3, ran all the updates, logged into an X11 session and installed the Zoom client (version 5.16.2). Yet, when trying to share the screen, I don't have the option to select a screen to share. I get "Use system desktop capture", "Use system window capture" and "Whiteboard".

 

The following is from the ~/.zoom/logs/zoom_stdout_stderr.log

Linux Client Version is 5.16.2 (8828)
QSG_RENDER_LOOP is
XDG_CURRENT_DESKTOP = ubuntu:GNOME; GDMSESSION = ubuntu; XDG_SESSION_TYPE = x11
Graphics Card Info:: 0000:00:02.0 VGA compatible controller: Intel Corporation Device a7a0 (rev 04)
Zoom package arch is 64bit, runing OS arch is x86_64, snap package 0
AppIconMgr::systemDesktopName log Desktop Name: ubuntu

 

My X11 session is confirmed by the following:

 

$ echo $XDG_SESSION_TYPE
x11

 

Any ideas what could be causing this?

Select the "Use system window capture", then you should get a popup window to select the Application to share.

When I select either "Use system window capture" or "Use system desktop capture" and click the "Share" button, nothing happens. The dialog simply closes, no further dialogs open and nothing is shared.

Jgel
Listener

Try opening session with XORG. When starting your session, pick your user and then on the bottm right there is a configuration wheel, choose XORG. Then, my problem was solved.

The options I have on the gear icon of the login screen are: "Ubuntu Wayland", "Ubuntu", "GNOME Classic Wayland" and "GNOME Classic". I have been using "Ubuntu". I have tried "GNOME Classic" as well.

conneqt
Listener

On Ubuntu 23.10.  Installed Zoom 5.16.6 from the snap and ran into this issue.
Uninstalled the snap and then installed the 5.16.10 .deb from the Zoom download center

and sharing worked!