Showing results for 
Search instead for 
Did you mean: 

Unable to download meetings recorded on 'cloud'


I use a Mac. Normally when I have recorded a meeting on the cloud, I can click on the three dots to the right of the recording and click on the 'Download' button. Immediately the files whizz up to the top of the screen to show the downloading process has started, with the progress showing as it downloads. Now when I click on DOWNLOAD, nothing happens. I have checked my download folder to see if they have actually downloaded and no sign of the files. I have also tried to use the 'share link' and passcode and download that way. That doesn't work wither. My employer and meeting participants are waiting for the recordings. Has anyone had this problem and found a solution to it?



I am having the exact same issue - have always recorded to the cloud then download on my mac - but suddenly there is no response when I download the file - nor does it play online even though it displays how long the recording is so it must be there. Frustrating - especially since on one has responded to your problem - can't find the solution.


Hi Dave. I did a full shut down of my laptop and any zoom applications and it seemed to set the problem. You’ve probably tried this but thought I’d mention it in case. Often I just close my laptop and don’t do a proper shut down.  Maybe it needs the shut down to update something crucial for this issue.