Ready to set up and use Zoom, but aren't sure where to start? Begin with our onboarding support experience for everything you need to get started.

Get Started
cancel
Showing results for 
Search instead for 
Did you mean: 

SilentAutoUpdate MSI

Iconiu
Observer

Who has a working installer command line for silent auto updates?

 

I've read through the MSI deployment several times and tried 14 command line variants for installation but cannot get the zoom client to silently auto update.   My latest attempt looks like this.

 

ZoomInstallerFull.msi" ZoomAutoUpdate="true" zNoDesktopShortcut="true" zConfig="NoGoogle=1;NoFacebook=1;AutoUpdate=1;EnableSilentAutoUpdate=1" /qn /norestart

 

It is not clear if options should go under zconfig or are a direct MSI property.   This command writes these keys to the registry.  I am not directly editing these values.  They look like they should work but it's not auto updating, even after joining and exiting a meeting.  My package installs version 5.6.7 which is not the latest version.  

 

HKLM\Software\Zoom\MSI

- DisableUpdate false

- Home c:\program files\zoom\bin

 

HKLM\Software\ZoomUMX\PerInstall

- autoupdate = 1

- enablesilentautoupdate = 1

- enableupdate = true

- nodesktopshortcut = true

- nofacebook = 1

- nogoogle = 1

-zconfig = "NoGoogle=1;NoFacebook=1;AutoUpdate=1;EnableSilentAutoUpdate=1"

 

Under EnableSilentAutoUpdate the guide says that AutoUpdate needs to be enabled.  But which auto update?   ZoomAutoUpdate is enabled but just "AutoUpdate" is only referenced in the Outlook add-in section.   

 

 

1 ACCEPTED SOLUTION

Iconiu
Observer

It seems I am just impatient.   We don't have Zoom set to auto open and it doesn't check for updates unless it is open.  Opening Zoom, waiting a few minutes, closing, then re-opening triggered an update with the above settings.  

View solution in original post

1 REPLY 1

Iconiu
Observer

It seems I am just impatient.   We don't have Zoom set to auto open and it doesn't check for updates unless it is open.  Opening Zoom, waiting a few minutes, closing, then re-opening triggered an update with the above settings.