Introducing the new Zoom Community Champion Program where we recognize our most engaged community members for their contributions.

Learn more and join
cancel
Showing results for 
Search instead for 
Did you mean: 

Share Screen with Sound, Do Not Want To Hear Audio On Sharing Device - Using Mac

Jason_Estey
Listener

I have a scenario where 2 laptops are in the same space, one is hosting and the other is presenting a video with audio. The hosting laptop is connected to the room system, so any audio coming from the host computer will be amplified to the room. This includes any audio that the presenting laptop screen shares.

 

So to avoid an echo, it would be ideal for the presenting laptop (MacBook) to screen share with sound, but not output audio to the laptop. I want the laptop to only output audio to Zoom. But the volume of the screen shared audio seems to be tied with the laptop output volume. If I mute volume output on the MacBook, the screen shared audio is muted. In the Zoom meeting if I "Leave Computer Audio" the audio is still heard both through the laptop speakers and the screen share.

 

What I really need in Zoom is a "Select a speaker: None" option. The fix right now is to plug in headphones.

 

Is there a way to screen share with audio but not output audio to the computer (specifically a Mac)? Thanks!

2 REPLIES 2

Ray_Harwood
Community Champion | Customer
Community Champion | Customer

Hi, @Jason_Estey,

 

I don't think you can get Zoom to stop that audio from traveling from the sharing computer to the other computer, and you're correct, there's no way to stop the receiving Zoom computer from outputting at all (I'd also occasionally like a "no speaker" selection), but I'd think you could turn the speaker volume all the way down.

 

I'm not a "Mac person", though I have a Mac Mini for testing.  I found this Apple article which might help you -- it worked for me:

https://support.apple.com/guide/mac-help/adjust-the-volume-mchl1f98810b/mac 


Ray - GoodClix.com / BusinessIsZooming! Podcast / aka "Old Desert Lizard"
Please mark solutions that helped you !

Hi Ray,

 

Unfortunately I'm trying to mute the audio from the outputting/sharing computer, not the receiving computer. While screen sharing with audio, if I try to mute or lower the outputting computer's speakers the shared audio is also muted or lowered. Strangely this happens even if the audio output is set to ZoomAudioDevice in System Preferences>Audio>Output. If I switch the output to MacBook Pro Speakers (the built-in speakers) the shared audio isn't heard at all from the receiving computer. But also strangely, sometimes when I've tested screen sharing with audio ZoomAudioDevice doesn't show up as an output option in System Preferences. Yet the receiving computer still hears the shared audio. In those cases the output is set to MacBook Pro Speakers.

 

BTW I'm using macOS Catalina v 10.15.7. It's possible later OS versions don't have this issue.

 

So far I found one workaround: the advanced video share option does have independent audio control. While sharing a video using this feature, I can mute the sharing computer's speakers and the shared audio is still heard on the receiving computer. But that only works if I'm sharing a video file. Sharing computer audio, or a presentation that has video/audio in it, will continue to have a problem.

 

Jason