Showing results for 
Search instead for 
Did you mean: 

Screen Sharing on iPad (mostly) not working any longer


Hoping to get some help here.

I've been using Zoom to host meetings on my iPad and I need to share my screen. For nearly three years this has worked perfectly fine. Since the beginning of the year this function became unreliable as I had to frequently cancel and then retry the screen share before it worked. Over the past few weeks this has completely stopped working. I've done everything from ensure IOS is properly updated to deleting the Zoom app and then reinstalling. During a few tests with an internal team member it did work one time, but that was it.

Anyone else having this problem? I tested this on my iPhone and at least that one test worked fine. Not sure why it is so buggy on the iPad.

Thanks in advance for any help.



Update: after several weeks of being pinged around by Zoom reps who were not technical support, I finally got to someone who did indeed confirm this screen-sharing issue on the iPad is a known problem. I'm currently using a 'test' package version of the app that has solved the problem. The 'fix' is going to be coming on March 19th according to a message I got back from Zoom.

View solution in original post

I turned off Stage Manager and it WORKED! 

View solution in original post



I use iPad for teaching. Whiteboard was working fine for a long time but it has started playing up since last month. I can’t use my iPencil in a regular fashion, it just gets stuck to one icon and then it won’t work on any other icon although I can use my finger to activate different icons. It is unfortunate as I used Zoom to tech students for hours and was thinking of becoming a paid Zoom member. I wonder whether there is an ' easy solution to fix it.


Same thing is happening on my end.  When I plug the cable in to share my ipad or to do it wirelessly, my participants only get a black screen.  I'm using a macbook pro, OS 13..2.1 Ventura and my zoom is the latest update. 


Update: after several weeks of being pinged around by Zoom reps who were not technical support, I finally got to someone who did indeed confirm this screen-sharing issue on the iPad is a known problem. I'm currently using a 'test' package version of the app that has solved the problem. The 'fix' is going to be coming on March 19th according to a message I got back from Zoom.

Good deal 🙌🏼🙌🏼 thanks for posting their reply. This is a big issue. Hopefully they can do this sooner. I’ve been using this feature constantly. 

Hello what is a test package version please tell me about it , i am a teacher and it’s really disturbing me .please help me out


The issue still persists in Zoom 5.14.2 version with iPadOS 16.4.1. After broadcasting the screen, it displays a static picture instead of a realtime screen.

Interesting. I did FINALLLY get things working after a support call with someone from Zoom late last week. I have the updated version of Zoom, but have not updated iPad to most recent update just yet. Maybe I should not! I have not had many meetings since the support call last week, but the initial test was positive.

The screen sharing works fine in my colleague's ipad who using Ipad 

OS 16.3.1 version. I will try to re-install the Zoom aps

Reinstalling the Zoom doesnt solve the issue. So I guess it is due to OS update. Maybe wait for another Zoom update

Are you working with a Zoom tech person? I just sent a message to the person I was working with to let them this is clearly still an issue. Based on your experience I'm going to hold off updating my iPad! 

Thank you for reporting this issue to your customer service contact. I only reported this issue through regular reporting channels in the App since I have not contacted the CS. Hopefully, it will be resolved in the future update. 

Hello did you find any solution for this issue 


Same thing happening with me.


When is this going to be OK?

When I share iPad pro screen it freezes


Screen sharing is not working properly after updating to iPas OS 16.5. People cannot see a frozen screen, they don’t see what I am doing on my iPad. I deleted and reinstalled the zoom App v5.14.7  but it does not work. Any ideas.


This is still not resolved. Is there going to be an update?


I’ve been running into this issue for the last six months. I primarily use this iPad to share my screen and show my clients concepts and present via drawing everything out with the Apple Pencil. I tested out the screen sharing issue with my other PC and about nine out of every 10 times I’m running into the same issue as folks are describing here on this board. I don’t use the iPad for anything else other than presenting; I don’t use the camera on here I don’t connect to the audio. I strictly use it for presenting. Something that’s also peculiar that I’m running into is that when I start sharing my screen on the iPad it automatically makes me connect to the audio when I don’t want it to, which was never an issue before. So I have to manually go in and disconnect from the audio on my iPad since I’m already connected on my PC. You guys need to fix this issue as it’s been going on for longer than half a year. 


This just started happening to me this week. I go to share my screen of my iPad Pro and it freezes without going into the apps I’m trying to project to a class in an online course. This needs fixing asap. 


Hello did you find any solution to this issue 

So, the problem at one point seemed fixed, and then it did come back intermittently, but mostly worked through the summer. Since my iPad Pro was more than six years old and was clearly in need of a refresh I did purchase a new one in early September. Since then I have had no problems with the issue.


I actually ended up with the same problem.

When starting the screen sharing from my iPad Pro 6th generation with the M2 chip, the video freezes after a couple of seconds. 

I found this happens when activating the stage manager. If I turn off the stage manager, the screen sharing works - albeit it lags sensibly.

So for me, the solution is to turn off the stage manager before sharing the screen.


I hope this helps someone else too.

I turned off Stage Manager and it WORKED! 

Yes. I did that and it works. Thank you @shawoo 


I am having the same issue, I have deleted and redownloaded Zoom muliple times, but I still can't share the screen of my iPad. HOW TO FIX this? And the stage Manager tip did note work


I'm having this issue too.  Teachers need this to work. 


It worked all through the pandemic and now not working?!  This needs to be fixed soon, students are sufferings!


I used to be able to share screen on my iPad without any issue (4 months ago, all was good). Now I get kicked out of zoom meeting on my iPad after a few minutes of screen sharing and need to rejoin the meeting. Is there anyone from zoom tech services reading these messages and when can we expect a fix?



Not working.

I am using updated MacOS Sonoma on M3 MacBookPro with updated iOS 17 on iPadPro. MacBook and iPad are on the same sub-net with the same router: screen sharing invoked by selecting "iPad via AirPlay" (i.e. wireless connection) no longer works. I do not see the "Zoom" option in the iPad Screen Mirroring options (well I actually saw it once or twice briefly but it promptly disappeared). Strangely, if I connect via a USB-C cable it does work and the Zoom option is available as a mirroring selection. If I disconnect the cable while sharing the screen, I see a static image of the iPad (but no error from Zoom). Screen sharing also works if I select "iPad via cable".

Following previous posts here I have Stage Manager disabled and the AirPlay Receiver option was never enabled.

I am not sure when this stopped working but I used it often in the past.


Hello there, I am an online teacher who has been using Zoom for many years with a paid subscription. After dozens of e-mails back and forward with Zoom technical support and getting nowhere I cancelled my paid subscription. I have even factory reset my iPad three times. 


I had an also Apple support trying to help me out, but without any result. The “excuse is that I use “iOS Beta”.
I have left the beta program and will try to factory reset again today using “iTunes”, because according to Apple Support this could be the reason. They are not able to confirm I can do it without iTunes. 
After I have done it I will come back here to share with you guys. I am really pissed off, as I need Zoom to give classes. 
I have been using Google meet in the meantime. 

I'm having very similar issues.  One fix I've been told about but have not tried is mirroring with apple TV and sharing to Zoom.  I've not tried it yet.  Just got my school to get the iPAd, now I have to ask for an Apple TV!  pissed!

I just marked this topic as "New" (go to top right side of page and hit the three vertical dots).  


I noticed this stream was "solved" so I thought would not hurt.  Clearly not solved!


Have you tried disabling the stage manager? 
That solved my problems... and also others confirmed that here

I've never had stage manager on so that can't be the problem for me. 


Doesn't work for me.


The issue is still present with the latest Zoom update, version 5.17.10 (30974), with the latest MacOS Sonoma update (14.3.1).


I have also started running into the same issue on my iPad - was working fine for years until now. Had been acting up the past couple of weeks but now just won't stay open at all. Wondering if there's a fix for this? And I've had Stage Manager off this whole time.