Showing results for 
Search instead for 
Did you mean: 

I can't log in zoom with Google account.


Hi there, I was wondering if you can help me out.  I installed Zoom 5.7.5(1020) and I clicked on Google account to log in but the software didn't respond. Also I tried to click other button only log in worked.


Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hello Terry, after your installation , have your tried to reboot the computer? Or did you try to close the app and re-open it. Seems the application is stuck for some reason. Maybe the application was not installed properly. If it is still the same issue after you reboot the computer, i recommend you to uninstall the Zoom app and download it from Zoom office



This is also an issue for me


I click the Google icon to sign in on the Zoom Client application on my Mac, and after clicking on my account to sign in I receive a 504 Error



this is also issue for me i deleted zoom and installed then i shut down my computer then tutned it on again it is still not working


Worked like a dream.  Sorry I had to miss 2 meetings before I found out what was wrong!!!  Thanks!