Showing results for 
Search instead for 
Did you mean: 

How do I stop Zoom from auto-downloading the installer?


How do I stop automatically downloading a desktop client(exe) when I join Zoom meeting on a browser?
I have never installed Zoom desktop client and do not want to download it.
However, when I join Zoom meeting on a browser which is invited, Zoom desktop client is downloaded everytime.
Is it possible to stop downloading it automatically?
If possible, could you tell me the way to do that?
Thank you.


Community Champion | Customer
Community Champion | Customer

Hi, @itfreshman1 


You can join via browser from the link at the bottom of the screen that appears when you click on the URL link for a Zoom meeting, so you don't need to install the Zoom app!

Joining a Zoom meeting – Zoom Support



Please mark this post Accepted if it helped you !


Hi, @Ohkawa

Thank you for replying,

but the Zoom app is still automatically downloaded.

After clicking the URL link of Zoom meeting, I do not click any button and the app is downloaded.

It is so annoying.

Any solution to this?

Community Champion | Customer
Community Champion | Customer


It seems that the meeting host has a setting that prohibits participation from the browser, so you may want to ask them to allow it.




Thank you @Ohkawa ,

I did not know the settings, so it could be helpful for me.

I changed the settings and tried again, but the issue is still occurred.


Is that because of me using the basic licence?

Thank you.

Community Champion | Customer
Community Champion | Customer


It must be set by the meeting host, not the participants.


I am sorry for the lack of explanation.

I used two PCs, so I hosted the meeting on the one and joined with the other.

Under the condition, the issue is still occurred.

It seems like I need to give up.....


@Ohkawa or whomever else

I think I have a similar but perhaps the opposite problem. I have the Zoom app on my MacBook and on my iPhone. Every time I click on a link to a Zoom meeting when using my laptop, a new Zoom installer package downloads. I have no option to refuse or cancel it. This never happens on my iPhone, even if I am signing in with both devices to the same meeting, meaning that the settings by the host aren't dictating that the download occurs (unless of course every single host has chosen to make laptops download the app but not phones). As soon as the download is over, my existing app opens and I'm able to join the meeting. If I have a day during which I am joining multiple meetings, that many installer packages are in my download folder by the end. How can I make this stop? 

This is happening to me now... any fix?


Add "#success" at the end of a link without a slash, e.g.


This worked for me:

  1. This will give you the option to cancel the download if a site tries to download a file.

    1.1. On your computer, open Chrome.

    1.2. At the top right, click on the three dots for More, then click Settings.

    1.3. Under Privacy and security, click Site Settings.

    1.4. Scroll down and click Additional permissions.

    1.5. Click Automatic downloads.

    1.6. Switch on the Ask when a site tries to download files automatically after the first file (recommended) option.

  2. Use a Chrome extension: There are several extensions available in the Chrome Web Store that can help you block downloads from specific sites. Please note that you should only install trusted extensions, as they can access all your browsing data. One of such extensions is uMatrix which gives granular control over what a website can and can't do, including preventing downloads.

  3. Block pop-ups: Many unwanted downloads are initiated through pop-ups. You can block pop-ups by going to Settings > Privacy and security > Site Settings > Pop-ups and redirects and turning the setting to Blocked.