Showing results for 
Search instead for 
Did you mean: 

External Webcam Not Working on Zoom - Black Screen


My external webcam was working fine with Zoom for months and then all of a sudden sometime in the past two weeks, it stopped working and instead my video is a black screen to participants and to myself. I tested this same external webcam with Google Meets and it's working fine on Google Meets so it's definitely something with Zoom.


My built in Mac Air laptop camera does work with Zoom but I cannot use it for meetings because it is damaged and I look blurry which is why I have been using the external webcam these past few months for Zoom meetings.


I tried the following to troubleshoot: uninstall/reinstall Zoom, upgrade my Mac software, restart computer, go into Zoom video settings to check everything; check my privacy/security settings to make sure Zoom has access to my camera.

Anyone else have a similar issue or know how to resolve?


Community Champion | Customer
Community Champion | Customer

Please provide the make/model of the external webcam, as well as any additional details regarding how it's connected to the Mac (if it's USB-A, modern Macs only have USB-C/TB connections, so let us know if you're using an adapter).

Google Meet uses WebRTC (browser-based access to the camera). Can you confirm the camera works in PhotoBooth?

If you're able to provide the PID/VID of the external webcam, that's helpful as well.

I have the same problem.  My external webcam is EMEET SmartCam C950.  Any suggestions?


Thank you for your reply and questions. I appreciate it! I just checked and my external webcam does work fine with Photobooth so it's not the connection or the webcam that is the issue. I have a 2020 Mac Air laptop so I use the USB-C/TB connection to connect my webcam to my laptop. I am using an adapter.

Here is the webcam info:
Amazon link:
EMEET C950 Webcam
HD 1080P
70 FOV (viewing angle)

I could not find PID/VID info.

Community Champion | Customer
Community Champion | Customer

Got it - thanks for the info!


Have you tried a different port and adapter already?

Also, are you able to test this on a Windows PC to see if Zoom Client for Windows is having an issue with the camera as well?


I'd suggest starting by opening up a ticket with Zoom Support in the case that there is some type of hardware restriction (if your plan allows you to submit tickets). They will most likely ask for PID/VID, which you'll need to look up as well.

Thanks for your help in trying to troubleshoot. I tried the different port and adapter. It's definitely the connection between this particular camera model and Zoom (but after a recent Zoom update) since it worked fine until then. Also, the camera works fine on all other video applications like Google Meet, Facetime etc. 

My fix was to try a different camera which seems to work fine with Zoom so I am going to contact the EMEET company and see if I can return it. 


I have this same camera and problem. Were you able to get any support/resolution from the Zoom team on this?

No I could not get it resolved with this EMEET camera; however I used another camera and it worked on Zoom so my guess is that the new Zoom update was not compatible with the EMEET camera. My EMEET camera does work on Google Meets and other video platforms. It was very frustrating to try to resolve. 

Oh man! What cam did you end up getting? What were the specs you looked for in the cam to ensure it was compatible with the latest Zoom update?

This was an old webcam laying around the house that I bought on Amazon awhile back. I looked and it's no longer available but brand is Ylife - 1080 HD Webcam

I tried all of these but unfortunately NONE of these were solutions to my issue.

Hi! I just wanted to chime in that I have the same webcam and have the same issues with it not working on zoom (works fine on google meet). One thing I've been able to do is factory reset it each time when I'm on zoom through the EMEETLINK app. The only issue is that if you turn off your camera on Zoom and try to turn it on again it won't work. Then you have to factory reset it again (and for some reason sometimes this will turn the saturation to 0 capacity and everything is in black and white). And if you factory reset to 2+ times, the webcam freezes for me and won't work on zoom again. I've been trying fix it but don't have any good solutions either. I tried uninstalling zoom and emeetlink, but the issues still persists. Thought I would share!

My device info in case someone else has any new ideas to try: 

HD Webcam eMeet C960:

Product ID: 0x006d
Vendor ID: 0x328f
Version: 2.02
Speed: Up to 480 Mb/s
Manufacturer: EMEET
Current Available (mA): 500
Current Required (mA): 500
Extra Operating Current (mA): 0


Had similar issue of no video. For me solved it by going to video settings in Zoom and check box HD


This was after hours and hours of trying uninstalling zoom and installing the latest Zoom again and then uninstalling and installing a previous version of Zoom. Also ordered two new C960 webcams which had the same black screen issue -- returned them to Amazon.

This totally fixed it for me! Thank you @Geraldca


@regexAZ@sczoom@bstrelko: this made my Emeet webcam work. Settings>Video> check "HD"


Thanks guys!!

Thanks. The Checking HD in the video settings did the trick.

Thanks so much

This also worked for me!! Thank you!!!!!

Worked great!!!   THANK YOU SO MUCH!!! 🤠

Actually, it's stopped working. Must be a new update?

Yay, Geraldca for the win!!! Check HD box worked for me too!

Listener | Zoom Partner
Listener | Zoom Partner

Omg, thank you!  I've been fighting with this for two weeks after a Zoom update, and this was all it took to fix it.

Hi:  I have the same problem with Zoom.  However, I cannot check the HD box as it is not available.

Solved the problem for me... you are a life saver! this is the only thing I didn't try til I saw your comment!

This fixed my issue immediately. Thank you thank you.

Thank you SOOOOOOOOOOOOOOO much for this!

Thanks @Geraldca . This worked for me!!!

That fixed it for me as well!  Thank you @Gerald!ca


Zoom => Video Settings ==> check box HD


Yes mine is doing the same thing. I have tried the same solutions to no avail. I have a emeet C950 camera


clicking on HD box in the video settings fixed it for me too!


I have the same camera with the same issues. However, I cannot select the HD box in video settings. It's there, but the box is greyed out.


I am having the same problem but there is no HD option to click on.  Are there any fixes for this as I have a EMEET C960 camera.


I have the same issue, but unfortunately checking HD doesn not solve it for me. I use a KanDao WL0308. I've deleted and reinstalled Zoom, tried different USB ports and checked on other apps (Photo Booth, the external camera works).


I remembered I had the exact same camera at home (Emeet C950), so I brought it to work and it works fine. So, it must be something wrong with the camera itself, at least in my case.



I have same problem.  Reinstalled zoom.  didn't help