Introducing the new Zoom Community Champion Program where we recognize our most engaged community members for their contributions.

Learn more and join
cancel
Showing results for 
Search instead for 
Did you mean: 

EnableSilentAutoUpdate

andymax
Listener

I'm trying to enable the silent auto update feature without any luck so far. If I understand correctly,  with EnableSilentAutoUpdate set to enable, Zoom should automatically update on launch. I've tried various combinations of settings and none of them work. This is my current command options -
'/quiet /qn /norestart ZoomAutoUpdate=1 AlwaysCheckLatestVersion=1 EnableSilentAutoUpdate=1 MSIRESTARTMANAGERCONTROL=0 ZSSOHOST="XXXXXX.zoom.us" ZNoDesktopShortCut=true ZConfig="DisableLoginWithEmail=1;nogoogle=1;nofacebook=1;login_domain=XXXXX.edu;kCmdParam_InstallOption=9"'

Any help would be appreciated. Thanks.
Andy

4 REPLIES 4

Bort
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @andymax 

Two things to note: 

  1. EnableSilentAutoUpdate=1 should be included with the zConfig section, thus: 
    msiexec /i ZoomInstallerFull.msi ZoomAutoUpdate=true ZConfig="EnableSilentAutoUpdate=true"
  2. This may not always trigger an update, as this will only update to the latest stable version, as defined by our Engineering team. 

Bort,

Moving EnableSilentAutoUpdate to the zConfig section got me a little closer (see attachment) but, it's still not updating. Can you tell me if the update should take place immediately after starting zoom or will the user need to log in before it will update? I'm installing 5.7.4.804 so I assume that there should be a stable update available. My main test machine is a Hyper-V virtual machine. I've also tested on a physical machine with the same results. Although there are errors in the logs the installation completes with an exit code of zero.

 

Thanks for your help.

Andy

Bort
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Hi @andymax 

As far as I know, the update will only happen when the app is restarted or the user clicks the Update button. This is one reason the update may not be occurring. 

Another reason is that using the EnableSilentAutoUpdate will only update to the latest stable version, which seems to be set as 5.7.7 (as of this weekend). If the version you're currently on was above the set stable version (even though there are more recent versions available), it will not update the app until a new stable version is set or available. 

I'd see if your test deployments update now that the stable version has been moved up to 5.7.7

cannonz
Listener

For the automatic silent update to work, is the "enableupdate" registry string required?   We have seen inconsistent results with a few test machines having just the "EnableSilentAutoUpdate"="1" and  "SetUpdatingChannel"="0".  We also have a few test machines that also have the enableupdate = 1 string added.  We are hoping to not expose any of this configuration to the user.