cancel
Showing results for 
Search instead for 
Did you mean: 

Dual monitor lack of viewing options when screen sharing a Keynote presentation

EllaPyves
Listener

I have recently added a second (larger) display to be able to view the participants in zoom meetings, as my MacBook Air screen is too small to see all participants clearly in meetings of more than 9 people.

So far, so good, once you figure out how to show all the participants on the second monitor - for some reason it defaults to only show my self view on the second display. I can drag the main Zoom window across to the other screen, which also moves the controls across - annoying, but at least it works.

 

The challenge comes when I try to screen share a Keynote presentation.  For some reason the Keynote shows up in full screen on the second monitor, and there is no way to reduce the size of it and still show the participants next to the shared content, as it would be possible if I were a participant and the host shared their screen. There are no controls available anywhere on either screen while the screen share is active, except to close the Keynote presentation. 

 

I don't know if this is due to settings within Zoom; within Keynote or within the Mac OS. It's a 2020 MacBook Air running on the latest OS 14.3 with all app updates done and Zoom kept up to date. The additional monitor is a 2020 Dell which works fine otherwise.

 

Has anyone found a workaround or the correct settings to solve this issue? Or is this something that needs to be added in a future Zoom update? 

1 REPLY 1

sjmackinder
Listener

I have found out that this can be done with Zoom Room option but at a huge cost. The second screen should always be able to show participants, it should be an option. What is the point of showing only the host? The only way to get participants on a second screen is to duplicate displays and then you have to put up with the control bar on the bottom of the screen. This looks terrible and makes the presentation look dreadful, this has not been thought out at all!