cancel
Showing results for 
Search instead for 
Did you mean: 

Black screen when sharing screen on Wayland (Fedora 36, GNOME, 5.11.10.4400)

monosoul
Listener

Hi!

 

I use Fedora 36 with GNOME DE and Wayland. Whenever I'm trying to share a screen using the app other people are just seeing a black screen. I can confirm this behavior if I do a recording.

 

My setup:

OS: Fedora Linux 36 (Workstation Edition) x86_64
Host: 20VX006CGE ThinkPad P14s Gen 2i
Kernel: 5.19.7-200.fc36.x86_64
Resolution: 3440x1440
DE: GNOME 42.4
WM: Mutter
CPU: 11th Gen Intel i7-1165G7 (8) @ 4.700GHz
GPU: Intel TigerLake-LP GT2 [Iris Xe Graphics]
GPU: NVIDIA Quadro T500 Mobile
Memory: 13640MiB / 31820MiB
15 REPLIES 15

ericyoung
Listener

Same for me, fedora 36, nvidia 3080ti, wayland.  both the rpm and flatpak are blank windows.

The wayland hump probably has 5 years to go.  gonna be quite a ride.

straurob
Listener

I'm experiencing the same behavior with Zoom 5.12. Zoom basically supports screen sharing since version 5.11 but it looks as if something broke again.

Hi @straurob, Have you been able to share screen/window in any of the previous versions (5.11.xx)?

I tried to downgrade to 5.11.10 but same issue..  I'll stry 5.11.9 which I found link

https://cdn.zoom.us/prod/5.11.9.4300/zoom_x86_64.rpm

 

Unfortunately, I haven't found any solution so far. The only thing which works for me is is using X11 instead of Wayland. There is also a support ticket for that case but it its final result is: "Wait until Zoom fixed this". 😑

 

I'll try your hint with using the nouveau driver although this has raised other issues on my system using two external displays.

Hi @straurob 

It looks like that reverting nvidia driver to nouveau works for some people.  It didn't work for me.

I had hooked up 2 extra displays on laptop, and everything seems to be still working fine with nouveau driver (apart from zoom window sharing 🙂

  I'm in a process of upgrading to Fedora 37, to see if any luck.

Link to mentioned post

https://community.zoom.com/t5/Meetings/Shared-Window-App-is-black-in-Fedora-36-zoom-5-12-6-and-earli...

 

DenisZ
Listener

I can confirm same issue also on F36 Wayland different laptops, always blank screen.  When I try to share on laptop with 2 additional displays, it will always put sharing controls on the laptop screen and not where sharing window is located.  I've tried 5.12.2 and 5.12.6 and same issue

DZv
Listener

Check if you are using nvidia driver, and try with nouveau and it should work

Sorry, but even using X11 is a better advice than this.

ridiculous advice

Well I've got it to work, by activating nouveau instead of nvidia module.  Doing 1 reboot before I start zoom meeting, doesn't seem too ridiculous of an idea, when I can use all the functions of the zoom client.  Not that one is doing much more on a computer while having zoom lecture/meeting, unless he has Jeffrey Toobin as a role model.

monosoul
Listener

By now even Telegram client on Linux has a properly working screen sharing in Wayland. Makes me wonder what's the issue with making it to work properly in Zoom.

ericyoung
Listener

The only real solution is to use the web version of zoom while on linux.

Web version of zoom scales 16:9 picture into 4:3 so it looks funny, and not settings to change it. (when external camera is connected)

Uxxnzjxmznzj
Listener

Xdnsksocxnxizikcxnsizozmxsnxnz9xicjdns ja ozkcmcnsns