Showing results for 
Search instead for 
Did you mean: 

Audio interface, guests get echo of their own mics, otherwise fine




Looking to solve urgently an audio echo issue.

I'm running Windows 10, Zoom version 5.16.10, and a Zoom Livetrack L-8 audio interface.


In the Zoom client, my mics and speakers are set to the L-8, and my mics and headphones are hooked up to that. The interface gets feedback from the computer in one stereo channel. When this is on, i.e. I hear my computer audio and my guests' microphones, the guests get an echo of their own microphones. Apparently due to this loop back through the audio interface.

When I turn the feedback channel down to zero, the guests' echo stops, but I also wont hear them, or my computer audio.

One way around this is to set my computer audio to the computer audio jack, and plug my phones in to the compure. This way I hear what I've recorded played back to me, But I won't hear any of my mics. That makes it a challenge to play music and produce soundscapes for my guests, as I essentially won't hear how I sound via the microphones, only how I sound in the room.

Any ideas how to get this to work so the guests won't have the echo, but I can still hear the microphones and myself?

Workarounds that are not ideal would be to simply drop any talking and exchanging of ideas via audio, and only get that in the chat. And another would be to divide the sessions in such a way, that before talking and feedback, I'd plug my phones into the computer and switch the output on the Zoom client and computer, and then switch back to the original setup for music and mute all guest mics.

Thank you for helpful ideas!




Okay, so there is a chance I get this to work by switching my Windows Playback device (from bottom right menu) back to default speakers instead of the audio interface.

It may be that the Zoom client directly outputs to the audio interface master out, and the Windows playback device will make a line input to the A-I that also somehow includes the input from my guests, don't know why. Will have to see if this solves. ❤️ 

Thank you!


Unfortunately the solution I tried didn't work.

Either I get audio from the computer via a line-in, that then results in an echo for the guests' own microphones, something I won't hear. Or I choose to not hear my interface-connected microphones, but do hear guests, by switching my headphones from the audio interface to the computer audio port. So, I'll switch between the two settings and let the guests know where we're going. Only using audio interface-headphones for parts where guest microphones are muted.