Introducing the new Zoom Community Champion Program where we recognize our most engaged community members for their contributions.

Learn more and join
cancel
Showing results for 
Search instead for 
Did you mean: 

2 SSO logins, can't switch

TomS
Listener

I have an SSO login for my company.  It works fine. 

 

I just received a 2nd zoom SSO login from an educational institution.  

 

When I use the desktop zoom client (windows 10, v 5.8), it automatically logs me into company sso account..

 

I need to sometimes switch to 2nd SSO account, but when I try "Switch accounts" or sign out and then go to sign in, when I choose the SSO option, it whips by and automatically logs me into the company SSO account.  I am not given a chance to type in a domain to log into the 2nd account.

 

How can I fix this? 

1 ACCEPTED SOLUTION

chgboyd
Listener

Any updates on this? I'm having the same issue on a Mac.

View solution in original post

25 REPLIES 25

Rupert
Creator

Hi @TomS 

 

I just tested this - and I was able to get this behavior:

 

Log Out in Zoom first.

Then go to login.

Choose SSO

Your organization SSO page will probably popup . CLOSE that page.

Behind that page should be the Zoom SSO domain input box

Input your other SSO domain and proceed to your login.

 

Does that work for you?

 

TomS
Listener

Thanks Rupert,

 

Sadly, no this does not work.  Desktop client - choose login, then choose sso - it just whips by the domain entry screen in a millisecond. I can see my company's domain there in the brief time it is shown (very very brief).

 

I saw this article:  https://support.zoom.us/hc/en-us/articles/360059970632-Auto-login-for-Office-365-add-in 

 

but I don't see the options they speak of so I can't see a way to disable this functionality (if this is indeed what is going on).

 


I do have the zoom outlook plugin installed - I tried disabling it in outlook but it had no effect.  And the article above talks about the web zoom portal and finding the option but I cannot find this setting anywhere in there.  It's possible this is out of my control (i.e. controlled by my company overlords).

 

I created a video but it won't let me upload it here - converted it to animated gif,  hopefully shows ok.

 

Tom

TomS
Listener

Well the workaround I found is to edit the file zoom.us.ini located here:

 

C:\Users\<username>\AppData\Roaming\Zoom\data\Zoom.us.ini

 

and remove the win_osencrypt_key line entirely.  

 

It then prompts me for sso domain.  

 

Perhaps there is a setting somewhere that says "do not remember my sso domain" but I can't find it.  This will have to do.

 

Tom

Well good find in the meantime!

Eaganeer
Community Champion | Zoom Employee
Community Champion | Zoom Employee

There is an MSI/GPO flag that admin's can utilize which will force the client to a specific SSO login. May be worth checking to see if your client was installed with this method. 

 

https://support.zoom.us/hc/en-us/articles/201362163-Mass-deployment-with-preconfigured-settings-for-...

Thanks Eaganeer - I see how they could set it during MSI setup, but I don't know how to tell if that has been done - I can't find any interesting registry keys that might hold this setting.  You don' t know where that setting lives, do you? 

 

The fact that I can override by editing the zoom.us.ini key and get prompted for sso info makes me think this is not in play (forced to specific sso).  I can switch between my company sso and the educational one by removing the line from the ini file and restarting.  It will remember what SSO to use until I clear it out again.

 

Tom

Try HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Zoom\Zoom Meetings\General.​

Thanks - unfortunately nothing for Zoom under HKLM\Software\Policies or HKCU\Software\Policies

Eaganeer
Community Champion | Zoom Employee
Community Champion | Zoom Employee

More information

 

The EXE installs in C:\User\****\AppData\Roaming\Zoom\bin and uses HKEY_CURRENT_USER\

The MSI installs in C:\Program Files (x86)\Zoom\bin and uses HEKY_LOCAL_MACHINE\

 

If the EXE is installed on a machine that has the MSI, the installation stops and the MSI is left.

If the MSI is installed on a machine that has the EXE, a cleanup process will remove the EXE installation before continuing with the MSI install.

 

If you can validate (and get exception to?) any IT policies that lock down SSO domain, then the following article provides guidance on how to switch accounts.

 

https://support.zoom.us/hc/en-us/articles/201362383-Signing-out-and-switching-between-accounts

KarinAlfrida
Listener

I have exactly the same problem, no solution to this yet unfortunately,  Drives me crazy… Any more suggestions, please?

probablynotNSA
Listener

I've been dealing with this for over a year.  Both my executive education program and my work are tech-savvy places that require SSO.  The workaround around here is to be quick with the mouse - you might be able to stop the page from loading once in five times.   If you win the race, you can go back to the "enter your domain" name to change the domain whose SSO is checked. 

 

Being forced to do this is totally unacceptable for a recipient of two very expensive enterprise accounts.  This is a known issue reported in multiple places without resolution.   Video conferencing is a commodity and Zoom's inability to address minor fixes like this will result in a market share loss quickly.  

I agree it should be fixed.  There is no way I could click fast enough.  My solution of editing the .ini file (well, using a batch file to overwrite ini file with one that does not have encryption key) works well enough for me - an inconvenience but doable.

I have the same problem.  What works for giving me enough time to close the browser before it logs me in automatically is to turn off the wifi before clicking on the SSO login button. To be specific:

 

1. Click Sign Out (Switch Accounts won't work)

2. Click Sign In

3. Disable internet connectivity (e.g. turn wi-fi off)

4. Click on SSO

5. Close the browser

6. Enable internet connectivity back (e.g. turn wi-fi back on)

7. Switch between SSO accounts by inserting your other organization's domain

drjuliet
Listener

I have the same problem. : (

 

bbgdjk
Listener

😘

 

 

 

laurabennett
Listener

e way i have found to do this is to log out of the Zoom desktop client, then go to https://portal.office.com and log out of Office 365 in the top right corner, then go back to the Zoom desktop client and sign back in, this will force the SSO authentication to go through the full sign in allowing you to enter the other emial account to sign in with.

 

chgboyd
Listener

Any updates on this? I'm having the same issue on a Mac.

Eaganeer
Community Champion | Zoom Employee
Community Champion | Zoom Employee

Is your Zoom client installation managed by IT?

Nope. I'm a solopreneur. 😉

Mine is.

Eaganeer
Community Champion | Zoom Employee
Community Champion | Zoom Employee

I did. Sadly, each time I try to select "Sign in with Google," it just shunts me back to the Zoom app, where I am still logged into my original account. See screen grab below.

 

2022-06-15 12.45.12.gif

@Eaganeer... aaaand... I just realized that this thread is technically about SSO logins, and not specifically Google logins. Perhaps it's a different issue...?

KarinAlfrida
Listener

Looks like the problem/topic is marked as solved -  it isn't is it? 

It's not solved. Steps to recreate on Mac 10.15.7 

  • open zoom from closed state
  • zoom will open safari tab https://[vanity].zoom.us/profile
  • the sign in with sso window will also open.
  • the pre-filled sso is not the correct one, and clicking "continue" will open a new safari tab with whatever profile/sso is signed in online. 
  • the field to edit the sso vanity name in the sso window will not be editable.